(自分メモ) Windows7新規インストール時にM-Track 2x2Mのドライバがデジタル署名うんたらかんたらの件

■問題
Windows7(Home Premium SP1)を新規インストール直後、M-AUDIOのM-Track 2x2Mのドライバをインストールしようとすると
「このドライバーはデジタル署名されていません」
とエラーが出てデバイスが認識されない(ドライバ自体はインストールされている)件。

(ver1.0.4と最新の1.0.6の両方で確認)

 

■解決
大人しくWindowsのアップデートの「重要な更新」を全部入れる。
その後インストールしたらすんなり入った。
(既にインストールして失敗している時は、一旦アンインストールしてインストールし直す)

 

これの検証で3回程OSのクリーンインストールをやり直した。
元々運用していたWindows7に後から買ってきたM-Track2x2Mを付け、ドライバをインストールした時は問題なかったのに、
今回CドライブのSSD換装によりOSをクリーンインストールした直後に「デジタル署名されてない」とエラーが出て「?」となった。

元々ウチの環境では最新の1.0.6だとプチフリみたいな症状が出ていた為、保存しておいた古い1.0.4をインストールしてのエラー。
なので、本当にデジタル署名が切れた?のかと思い公式のサイトから1.0.6を落としてくるも同じエラー。
流石に最新のドライバで署名切れはおかしいので、Webを色々と検索するも解決策は見当たらず。
(そもそも、時期で署名が切れたりするのかとか知らないケド…)

 

ところが、そうこう弄っているウチに何故かドライバがインストールできた。
その間に起きた事と言えば、何回かのWindowsのシステムのアップデートとそれによる再起動。

で、OSのセキュリティ関連のアップデートが臭いと睨み、もう一度Windowsをクリーンインストール。
マザーのチップセット関連のドライバだけ入れ、M-Trackのドライバをインストールし、やはり「デジタル署名うんたら」のエラーが出る事を確認した上でWindowsの重要な更新だけをひたすら全部入れ続けた。
(一度に大量に入れようとするとよく更新に失敗するので、なるべく小分けにして)

その後、先ほどインストールしてデバイスの認識に失敗していた1.0.6ドライバをアンインストールし、再度1.0.6をインストール。無事完了。デバイスも認識。
更にその1.0.6をアンインストールし1.0.4をインストール。こちらも問題なく作動。解決。

 

※2017/07/16追記
海外のフォーラムで記述を見つけたのでリンク。
http://community.m-audio.com/m-audio/topics/m-track-2x2m-no-longer-detected-hardware-not-connected-windows-7-64-bit

ここでもM-AUDIOの方と思われる方(Corey S氏)が同様の事を書かれてました。
以下自動翻訳。

「ドライバは完全に署名されており、Windows7〜10と互換性があります。誰もがこの問題を抱えているわけではなく、WIndows7で更新されていない更新プログラムにリンクしています。
Windowsの更新方法によっては、私たちのドライバは最新のシグネチャプロセスで署名されています。このアップデートがないと、システムを正しく読み取ることができません。
これにより、ドライバの署名が認識できないことを直接示すエラーが発生します。

これは主にWindows10ユーザーに影響を与えています。その時点で、ローカルWindowsサポートチームに連絡して、OSが正しくインストールまたは更新されていることを確認することをお勧めします。
Windows7を使用している場合は、バージョンが最新であることを確認してください。」

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)